Python: Δεν ενότητα που ονομάζεται core.exceptions

ψήφοι
2

Προσπαθώ να πάρει το Google AppEngine να εργαστούν για το Debian κουτί μου και εμφανίζεται το ακόλουθο μήνυμα λάθους όταν προσπαθώ να αποκτήσετε πρόσβαση στη σελίδα μου:

<type 'exceptions.ImportError'>: No module named core.exceptions 

Η ίδια εφαρμογή λειτουργεί μια χαρά για μένα όταν το τρέχω σε άλλες κουτί Ubuntu μου, οπότε ξέρω ότι δεν είναι ένα πρόβλημα με την ίδια την εφαρμογή. Ωστόσο, θα πρέπει να πάρετε αυτό που εργάζονται σε αυτό το πλαίσιο Debian. Αρχικά είχε python 2.4 αλλά μετά AppEngine παραπονέθηκε γι 'αυτό έχω εγκαταστήσει τα πακέτα python2.5 και python2.5-dev (χωρίς αποτέλεσμα).

Είδα αυτή την ανάρτηση Ομάδα Google που μπορεί να οφείλεται στην έκδοση του AppEngine και μόνο για να το εγκαταστήσετε ξανά, αλλά αυτό δεν λειτούργησε. Καμιά ιδέα?

Επεξεργασία 1: Επίσης προσπάθησε απεγκατάσταση python2.4 και 2,5 συνέχεια επανεγκατάσταση 2.5, το οποίο επίσης δεν λειτούργησε.

Επεξεργασία 2: Βγάζει όταν έκανα AppEngine σε ένα έργο CVS δεν προσθέτουν στον κατάλογο πυρήνα στο έργο μου, έτσι όταν έλεγξα εκεί έξω κυριολεκτικά ήταν καμία μονάδα που ονομάζεται core.exceptions. Re-λήψη αυτού του φακέλου επιλυθεί το πρόβλημα.

Δημοσιεύθηκε 07/09/2008 στις 19:57
πηγή χρήστη
Σε άλλες γλώσσες...                            


1 απαντήσεις

ψήφοι
4

core.exceptionsείναι μέρος του Django? ποια έκδοση του Django δεν έχετε εγκαταστήσει; Η AppEngine έρχεται με την κατάλληλη έκδοση για ό, απελευθέρωση που έχετε κατεβάσει (στο lib / directory Django). Μπορεί να εγκατασταθεί με τη μετάβαση σε αυτόν τον κατάλογο και να λειτουργήσειpython setup.py install

Απαντήθηκε 07/09/2008 στις 20:28
πηγή χρήστη

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more